const regex = /<a href=".*?"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href=".*?"', 'gm')
const str = `<td>
[<a href="/abc123/handouts/files/directory1/somename.pdf" target="_blank">Slides</a> ] [ [<a href="/abc123/handouts/files/directory2/somename2.pdf" target="_blank">Handout</a> ]</td>
<td>
[<a href="/abc123/handouts/files/directory3/somename343.pdf" target="_blank">Slides</a> ] [ <a href="/abc123/handouts/files/directory5/somename2324.pdf" target="_blank">Handout</a> ]
</td>`;
const subst = `<a href="#"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);