# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a href=\".*?\""
test_str = ("<td>\n"
"[<a href=\"/abc123/handouts/files/directory1/somename.pdf\" target=\"_blank\">Slides</a> ] [ [<a href=\"/abc123/handouts/files/directory2/somename2.pdf\" target=\"_blank\">Handout</a> ]</td>\n\n"
"<td>\n"
"[<a href=\"/abc123/handouts/files/directory3/somename343.pdf\" target=\"_blank\">Slides</a> ] [ <a href=\"/abc123/handouts/files/directory5/somename2324.pdf\" target=\"_blank\">Handout</a> ]\n"
"</td>")
subst = "<a href=\"#\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.