// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a href=".*?""#).unwrap();
let string = "<td>
[<a href=\"/abc123/handouts/files/directory1/somename.pdf\" target=\"_blank\">Slides</a> ] [ [<a href=\"/abc123/handouts/files/directory2/somename2.pdf\" target=\"_blank\">Handout</a> ]</td>
<td>
[<a href=\"/abc123/handouts/files/directory3/somename343.pdf\" target=\"_blank\">Slides</a> ] [ <a href=\"/abc123/handouts/files/directory5/somename2324.pdf\" target=\"_blank\">Handout</a> ]
</td>";
let substitution = "<a href=\"#\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}