# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(subject name=\"(?:Biology|chem102)\"[\s\S]+?)\r?\n^topic$|(^topic$\r?\n)/\1\2\n/gm;t' <<< "subject name=\"Biology\" value=\"12th\"
topic name=\"system\" value=\"anything\"
topic
subject name=\"mathematics\" value=\"12th\"
topic name=\"system\" value=\"anything\"
other topics =\"anything\" value=\"anything\"
topic
subject name=\"chem102\" value=\"12th\"
topic name=\"system\" value=\"anything\"
topic
subject name=\"ComputerSc\" value=\"12th\"
topic name=\"system\" value=\"anything\"
other topics =\"anything\" value=\"anything\"
topic"