using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(subject name=\""(?:Biology|chem102)\""[\s\S]+?)\r?\n^topic$|(^topic$\r?\n)";
string substitution = @"\1\2\n";
string input = @"subject name=""Biology"" value=""12th""
topic name=""system"" value=""anything""
topic
subject name=""mathematics"" value=""12th""
topic name=""system"" value=""anything""
other topics =""anything"" value=""anything""
topic
subject name=""chem102"" value=""12th""
topic name=""system"" value=""anything""
topic
subject name=""ComputerSc"" value=""12th""
topic name=""system"" value=""anything""
other topics =""anything"" value=""anything""
topic";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}