# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(subject name=\"(?:Biology|chem102)\"[\s\S]+?)\r?\n^topic$|(^topic$\r?\n)"
test_str = ("subject name=\"Biology\" value=\"12th\"\n"
"topic name=\"system\" value=\"anything\"\n"
"topic\n"
"subject name=\"mathematics\" value=\"12th\"\n"
"topic name=\"system\" value=\"anything\"\n"
"other topics =\"anything\" value=\"anything\"\n"
"topic\n"
"subject name=\"chem102\" value=\"12th\"\n"
"topic name=\"system\" value=\"anything\"\n"
"topic\n"
"subject name=\"ComputerSc\" value=\"12th\"\n"
"topic name=\"system\" value=\"anything\"\n"
"other topics =\"anything\" value=\"anything\"\n"
"topic")
subst = "\\1\\2\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.