const regex = new RegExp('(subject name=\\"(?:Biology|chem102)\\"[\\s\\S]+?)\\r?\\n^topic$|(^topic$\\r?\\n)', 'gm')
const str = `subject name="Biology" value="12th"
topic name="system" value="anything"
topic
subject name="mathematics" value="12th"
topic name="system" value="anything"
other topics ="anything" value="anything"
topic
subject name="chem102" value="12th"
topic name="system" value="anything"
topic
subject name="ComputerSc" value="12th"
topic name="system" value="anything"
other topics ="anything" value="anything"
topic`;
const subst = `\1\2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);