use strict;
my $str = 'subject name="Biology" value="12th"
topic name="system" value="anything"
topic
subject name="mathematics" value="12th"
topic name="system" value="anything"
other topics ="anything" value="anything"
topic
subject name="chem102" value="12th"
topic name="system" value="anything"
topic
subject name="ComputerSc" value="12th"
topic name="system" value="anything"
other topics ="anything" value="anything"
topic';
my $regex = qr/(subject name=\"(?:Biology|chem102)\"[\s\S]+?)\r?\n^topic$|(^topic$\r?\n)/mp;
my $subst = '\\1\\2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";