#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(subject name=\"(?:Biology|chem102)\"[\s\S]+?)\r?\n^topic$|(^topic$\r?\n)"
Local $sString = "subject name="Biology" value="12th"" & @CRLF & _
"topic name="system" value="anything"" & @CRLF & _
"topic" & @CRLF & _
"subject name="mathematics" value="12th"" & @CRLF & _
"topic name="system" value="anything"" & @CRLF & _
"other topics ="anything" value="anything"" & @CRLF & _
"topic" & @CRLF & _
"subject name="chem102" value="12th"" & @CRLF & _
"topic name="system" value="anything"" & @CRLF & _
"topic" & @CRLF & _
"subject name="ComputerSc" value="12th"" & @CRLF & _
"topic name="system" value="anything"" & @CRLF & _
"other topics ="anything" value="anything"" & @CRLF & _
"topic"
Local $sSubst = "\1\2\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)