import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(subject name=\\\"(?:Biology|chem102)\\\"[\\s\\S]+?)\\r?\\n^topic$|(^topic$\\r?\\n)";
final String string = "subject name=\"Biology\" value=\"12th\"\n"
+ "topic name=\"system\" value=\"anything\"\n"
+ "topic\n"
+ "subject name=\"mathematics\" value=\"12th\"\n"
+ "topic name=\"system\" value=\"anything\"\n"
+ "other topics =\"anything\" value=\"anything\"\n"
+ "topic\n"
+ "subject name=\"chem102\" value=\"12th\"\n"
+ "topic name=\"system\" value=\"anything\"\n"
+ "topic\n"
+ "subject name=\"ComputerSc\" value=\"12th\"\n"
+ "topic name=\"system\" value=\"anything\"\n"
+ "other topics =\"anything\" value=\"anything\"\n"
+ "topic";
final String subst = "\\1\\2\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}