#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(https?:\/\/)?(www\.youtube\.com\/watch\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?"
Local $sString = "https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s"
Local $sSubst = "https://www.youtube.com/embed/$3?fs=1&start=$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)