$re = '/(https?:\/\/)?(www\.youtube\.com\/watch\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?/m';
$str = 'https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s';
$subst = "https://www.youtube.com/embed/$3?fs=1&start=$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;