import Foundation
let pattern = #"(https?:\/\/)?(www\.youtube\.com\/watch\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://www.youtube.com/embed/$3?fs=1&start=$5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)