re = /(https?:\/\/)?(www\.youtube\.com\/watch\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?/m
str = 'https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s'
subst = 'https://www.youtube.com/embed/$3?fs=1&start=$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result