package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/)?(www\.youtube\.com\/watch\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?`)
var str = `https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s`
var substitution = "https://www.youtube.com/embed/$3?fs=1&start=$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}