using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/)?(www\.youtube\.com\/watch\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?";
string substitution = @"https://www.youtube.com/embed/$3?fs=1&start=$5";
string input = @"https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}