import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www\\.youtube\\.com\\/watch\\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?";
final String string = "https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s";
final String subst = "https://www.youtube.com/embed/$3?fs=1&start=$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}