use strict;
my $str = 'https://www.youtube.com/watch?v=e8WuGzXyO7Y&t=132s';
my $regex = qr/(https?:\/\/)?(www\.youtube\.com\/watch\?v=)([a-zA-Z0-9_-]+)(&t=)?([0-9]+)?(s)?/mp;
my $subst = 'https://www.youtube.com/embed/$3?fs=1&start=$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";