#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "&#(\b174;)"
Local $sString = "This is a registered company® and not for resale"
Local $sSubst = "®"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)