import re
regex = re.compile(r"&#(\b174;)")
test_str = "This is a registered company® and not for resale"
subst = "®"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)