const regex = /&#(\b174;)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&#(\\b174;)', '')
const str = `This is a registered company® and not for resale`;
const subst = `®`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);