use strict;
my $str = 'This is a registered company® and not for resale';
my $regex = qr/&#(\b174;)/p;
my $subst = '®';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";