using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&#(\b174;)";
string substitution = @"®";
string input = @"This is a registered company® and not for resale";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}