// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"&#(\b174;)").unwrap();
let string = "This is a registered company® and not for resale";
let substitution = "®";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}