import Foundation
let pattern = ##"&#(\b174;)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"This is a registered company® and not for resale"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"®"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}