# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*/\1 \2 \3/g;t' <<< "i.e., George W. Bush
Lyndon B. Johnson, etc."