using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*";
string substitution = @"\1 \2 \3";
string input = @"i.e., George W. Bush
Lyndon B. Johnson, etc.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}