// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*").unwrap();
let string = "i.e., George W. Bush
Lyndon B. Johnson, etc.";
let substitution = "\\1 \\2 \\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}