use strict;
my $str = 'i.e., George W. Bush
Lyndon B. Johnson, etc.';
my $regex = qr/.*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*/p;
my $subst = '\\1 \\2 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";