import Foundation
let pattern = #".*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
i.e., George W. Bush
Lyndon B. Johnson, etc.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2 \3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)