$re = '/.*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*/';
$str = 'i.e., George W. Bush
Lyndon B. Johnson, etc.';
$subst = "\1 \2 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;