#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*"
Local $sString = "i.e., George W. Bush" & @CRLF & _
"Lyndon B. Johnson, etc."
Local $sSubst = "\1 \2 \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)