package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*`)
var str = `i.e., George W. Bush
Lyndon B. Johnson, etc.`
var substitution = "\1 \2 \3"
fmt.Println(re.ReplaceAllString(str, substitution))
}