re = /.*([A-Z][a-z]+)\s([A-Z])[.]+\s([A-Z][a-z]+).*/
str = 'i.e., George W. Bush
Lyndon B. Johnson, etc.'
subst = '\\1 \\2 \\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result