# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\**\b(MUST)\b\**/**$1**/gm;t' <<< "This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced
"