re = /\**\b(MUST)\b\**/m
str = 'This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced
'
subst = '**$1**'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result