$re = '/\**\b(MUST)\b\**/m';
$str = 'This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced
';
$subst = "**$1**";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;