using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\**\b(MUST)\b\**";
string substitution = @"**$1**";
string input = @"This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}