import Foundation
let pattern = #"\**\b(MUST)\b\**"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"**$1**"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)