#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\**\b(MUST)\b\**"
Local $sString = "This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced" & @CRLF & _
""
Local $sSubst = "**$1**"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)