import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\**\\b(MUST)\\b\\**";
final String string = "This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced\n";
final String subst = "**$1**";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}