const regex = /\**\b(MUST)\b\**/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\**\\b(MUST)\\b\\**', 'gm')
const str = `This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced
`;
const subst = `**$1**`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);