package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\**\b(MUST)\b\**`)
var str = `This MUST should be caught, but not this one **MUST** because it is between ** but MUSTANG or WORDMUST are not replaced
`
var substitution = "**$1**"
fmt.Println(re.ReplaceAllString(str, substitution))
}