# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\+(\b\w{1,2}\b)/$1/g;t' <<< "+a +ab +string +of +words +with +different +lengths"