import re
regex = re.compile(r"\+(\b\w{1,2}\b)")
test_str = "+a +ab +string +of +words +with +different +lengths"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)