$re = '/\+(\b\w{1,2}\b)/';
$str = '+a +ab +string +of +words +with +different +lengths';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;