re = /\+(\b\w{1,2}\b)/
str = '+a +ab +string +of +words +with +different +lengths'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result