use strict;
my $str = '+a +ab +string +of +words +with +different +lengths';
my $regex = qr/\+(\b\w{1,2}\b)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";