import Foundation
let pattern = #"\+(\b\w{1,2}\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+a +ab +string +of +words +with +different +lengths"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)