package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+(\b\w{1,2}\b)`)
var str = `+a +ab +string +of +words +with +different +lengths`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}